DBLINK连接问题请教一下

请教一个问题,我在配置GBase的dblink,dblink已经建好了,在执行的时候提示:
gbase> select * from test@dblink;
ERROR 1105 (HY000): you need to add configuration for 'gbase_dblink_gateway_ip'  and 'gbase_dblink_gateway_port'.


我查看了一下操作手册,手册说配置这两个参数要在gbase_8a_gcluster.cnf这个文件中配置,但是我在文件夹中没有找到这个文件,请教一下这个文件在哪里?需要手动建吗?建在什么目录?

14 回答

grander 发表于 2018-6-26 17:42
图片确实看不见

能否看见?

好像还是不行,能留个微信直接联系吗
2018-6-26 17:48
图片确实看不见
2018-6-26 17:42
grander 发表于 2018-6-26 15:05
配置文件中增加如下两个参数,写在gbased配置节下。
gbase_dblink_gateway_ip=ip
gbase_dblink_gateway_p ...

是否能看到图片?我这边显示不出来
2018-6-26 16:54
grander 发表于 2018-6-26 15:05
配置文件中增加如下两个参数,写在gbased配置节下。
gbase_dblink_gateway_ip=ip
gbase_dblink_gateway_p ...

按照您说的配置如下,我的当前单机是192.168.252.128,想要连接192.168.252.130的gbase,端口没有设置过,使用默认的,

重启服务时报错:

system.log内容如下,

麻烦看一下问题在哪里,谢谢
2018-6-26 16:52
阿封 发表于 2018-6-25 18:20
[test@localhost GBase]$ gbase -uroot -proot123456
ERROR 2003 (HY000): Can't connect to GBase serve ...

配置文件中增加如下两个参数,写在gbased配置节下。
gbase_dblink_gateway_ip=ip
gbase_dblink_gateway_port=port

重启单机服务。如果启动服务报错的话,把报错信息和system.log中的内容发一下看看。

2018-6-26 15:05
grander 发表于 2018-6-25 18:10
看一下单机启动时system log里面报的什么错

能否给个微信的联系方式,这样沟通效率太低了
2018-6-26 08:56
grander 发表于 2018-6-25 18:10
看一下单机启动时system log里面报的什么错

[test@localhost GBase]$ gbase -uroot -proot123456
ERROR 2003 (HY000): Can't connect to GBase server on '127.0.0.1' (111)
这是链接时前台报的错,能否看出出错原因

2018-6-25 18:20
阿封 发表于 2018-6-25 14:10
我把这两个参数配置到了其中一个单机上的gbase_8a_gbase8a.cnf文件上,然后这个单机的gbase就登陆不上去 ...

看一下单机启动时system log里面报的什么错
2018-6-25 18:10
grander 发表于 2018-6-21 09:54
两个gbase单机?那可以将那两个参数配置到单机的配置文件gbase_8a_gbase8a.cnf中试一下
...

我把这两个参数配置到了其中一个单机上的gbase_8a_gbase8a.cnf文件上,然后这个单机的gbase就登陆不上去了,请问应该怎么配置?配置的格式有什么要求吗?
2018-6-25 14:10
12下一页

撰写回答

您需要登录后才可以回帖 登录 | 立即注册

提问者

发布3
回答14

相关资料